Customer Reviews
4.0 Based on 4 Reviews
Write a Review Ask a Question
  • Reviews
  • Questions

Thank you for submitting a review!

Your input is very much appreciated. Share it with your friends so they can enjoy it too!

Filter Reviews:
GW
16/04/2018
Gary W.
Canada
Great Service from the people at PI Speed Shps, as always.

Great product, works well and is very easy to configure.

KD
30/09/2017
Kenneth D.
Canada Canada
Fi tec 40019

This retro fit pump is awesome, the lowest profile out of all the retro fit pumps. And performance improvements were the only ones who seemed to have them in Canada. Decently priced and easy to deal with

Performance Improvements

Thanks for the five star review Ken! We do have FiTech and thousands more products, some not on our website ... yet. If you're looking for something you can't find anywhere else just reach out and we'll do our best to help you out

JC
07/09/2019
Jason c.
Canada Canada
Be prepared to work for it!

Not a great experience with this set up... removed and installed my tank in a c2 Corvette 4 times! And still have to do it one more time when my new pump arrives... straight forward installation, except for cheap parts! DO NOT USE THE HOSE THAT COMES WITH THE KIT! I installed the kit as per direction, first issue was top feed line hose clamp wont clear mounting ring to install pump, second, the cheap hose that comes with the kit softens to the point it leaks and causes the pump to run and bypass in the tank and cause a no start with the fitech unit... prior to figuring this out call fitech for a no start issue and well... still waiting to hear from them! So upon tank removal for the second time to try tightening the clamps provided to stop the bypassing I reinstalled the tank only to find it start bubbling in the tank again! Tank removal number 3... over tightening the clamps caused the hose to swell more and pop off the the unit... tank removal number 4... replacing the hose to a thicker, stronger piece... yep be careful you'll break the ****** off the pump, ask me how I know... fabricated a brass ****** to fit temporarily to get my car running using as mentioned a thicker hose only to find there is no way what so ever to put a hose clamp on the top of the hose from the pump as before just worst now because of the thicker hose.... to the hardware store, 1/8 brass extention, one 1/8 union and a 1/8 npt 3/8 ******... lowering the connection point for the hose, finally get the pump in the tank and voila! Car finally started two times in a row!!!! After a 3 day long ordeal... now having to replace the 340lph pump on my dime after spending 600$$$ on the unit... well this is the best I could come up with for a review that hopefully will help someone from the same headache in the future... Cheers!

GW
04/12/2018
Gary W.
Canada
Fi Tech

Great experience

Facebook retargeting pixel